
 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Introduction 

Preface 
The DX Navigator application uses standard Windows® keyboard and mouse operating 
conventions.  This helpfile assumes that the reader familiar with using standard Windows UI 
controls such as: dialog boxes, pull-down and contextual popup menus, standard and radio 
buttons, text boxes, spinners, checkboxes, keyboard shortcuts, sliders, tabbed windows,  list 
boxes, and drag and drop with the mouse.  This helpfile also assumes that the reader has 
already read the DX1208 Instruction Manual.  The manual provides an overview of both the 
hardware and software necessary to make full use of this helpfile. 

Definitions 
The following terms are used frequently throughout this helpfile: 

• Device Refer to either DX series hardware device, or any electronic 
appliance or device that can interact with both DX Navigator and 
DX series hardware devices, such as a computer, Ethernet switch, 
or printer. 

• Parameter This refers to anything in the software or hardware that can be 
adjusted by the user.  For example, equalizer gain, output delay, 
and automix ratio are all parameters. 

• Control A user interface or hardware item that provides the means to 
control or view a parameter.  For example, the equalizer 
frequency / gain handle in the EQ graph allows you to control both 
the equalizer frequency and gain parameters by dragging it with 
the mouse; a UR-1 remote control is a hardware device that 
allows you to control the assigned parameters using its encoder 
knob and button; the event log provides a way to view time-
stamped hardware events.  

• Setting Refers generally or specifically to the values of parameters. For 
example, ‘4 dB’ can be a setting for a channel or equalizer gain 
parameter. 

• Select / Selected Refers to using the windows cursor, by mouse or keyboard 
control, to highlight a control or object in a window. 

Conventions 
To add clarity to the text, this helpfile uses numerous typographical conventions to demarcate 
the terms or items being described from their normal or conventional use.  

• Capitalization Capitalization is used when referring to specific DX Navigator or 
Microsoft Windows software object such as a tab, window, button, 
parameter grouping, or menu names and items.  EX: the Settings 
tab, the Event Log, Permissions.  It can also refer to a DX 
hardware accessory or object.  EX: UR-1 Remote Control. 

•  [ abc ] Denotes parameter settings.  EX: [4 dB], [Slave], [Low] 

 2



• Italics Denotes the names of parameters. EX: Gain, Automix Ratio 

• Bold Denotes menu commands.  EX: Cut, Rename, Open 

• <ABC> Computer terminal typeface describes a keyboard or mouse 
action.  EX:  <CTRL+CLICK>  

• A > B > C Arrows refer to menu items and commands within a hierarchical 
menu tree.  EX:  File > Open  

Overview 

DX Navigator 
Description 
DX Navigator is a Microsoft Windows® application that provides a single user interface which 
can control and monitor a large array of EAWC DX series hardware devices at the same time.  
DX Navigator functions as the system management program for all of these devices by 
establishing the mode of communication to all of the devices, initiating and maintaining 
communications to the devices, and providing the means to upload and save unit configuration 
data to/from each device.  Multiple instances of DX Navigator can be run on different 
computers, allowing for simultaneous control or status monitoring of any device from different 
physical locations. 

DX Navigator can communicate to the DX hardware using whatever hardware interface is 
supported by the device.  The DX series hardware currently supports communication over 
10/100 Base-T Ethernet, RS-232, and USB 1.0/2.0.  All DX series hardware devices can 
communicate simultaneously over all supported communications interfaces.  For example, a 
DX1208 can simultaneously communicate with one local instance of DX Navigator via USB, 
and multiple remote instances via Ethernet.  Additionally, multiple external devices, such as 
AMD/Crestron controllers or EAWC UR-1/UR-2 Remote Controls, can be used to control and 
monitor system status using the RS-232, RS-485, and/or Logic I/O ports. 

DX Navigator runs on both 32-bit Windows XP and Vista operating systems; it does not 
presently support Windows XP 64-bit and Vista 64-bit operating systems. 

Main Window 
Launching DX Navigator opens the Main Window.  From the Main Window you can configure 
device communications settings, connect to and control different types of DX series hardware 
devices, and create and save offline device setups.  

The Main Window is divided into three tabs.  Each tab is a placeholder for icons that represent 
DX series hardware devices.  Device Icons have different functions depending on the tab they 
are located in. 

• Device Library The Device Library tab lists one Device Icon for each type of DX 
series hardware device currently supported in DX Navigator.  
Each Device Icon represents a blank (factory default) template 
from which device designs can be created.  Dragging a Device 
Icon from the Device Library to the Design tab creates a new 
device design. 
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• Design  The Design tab is the area where offline device designs are 
created.  Double-clicking a Device Icon in the Design tab opens a 
Device Window which provides access to all the settings of the 
device.  Design settings can be uploaded directly to hardware 
devices of the same type, and designs can be created directly 
from hardware devices.  The contents of the Design tab (one or 
more designs with their respective settings) can also be saved to 
a Site File on the local hard drive, and restored to the Design tab 
when the Site File is opened.    

• Found Devices The Found Devices tab adds a Device Icon for each physical 
hardware device that DX Navigator is able to connect to after 
going online.  Double-clicking a Device Icon in the Found Devices 
tab allows you to log into and control a hardware device directly 
from its Device Window. 

Device Windows 
DX Navigator interfaces to individual hardware devices through floating Device Windows.  
Each DX series hardware device has its own Device Window that provides the specific 
controls, configuration settings, and other parameters for operating that device type.  Device 
Windows opened from the Found Devices tab allow the user direct control over every 
parameter of the selected hardware device, as well as visibility to real-time meter data.  Device 
Windows opened from the Design tab, on the other hand, cannot control hardware directly.  
They are used instead to create offline designs which can later be uploaded to online 
hardware devices or saved to Site Files on disk. 

Main Window 

Communications Setup 
Description 
Before you can go online with any DX series device, you must first select the communications 
protocol you wish to use to communicate with the device(s).  DX Navigator offers three 
choices: RS-232, USB, and Ethernet (static or dynamic).  Once a protocol is selected, DX 
Navigator uses that protocol to discover and communicate with every connected device; 
protocols may not be selected on a per-device basis. 

Parameters 
The DX Navigator communications settings are accessed by choosing Tools from the 
Communications menu in the Main Window when DX Navigator is offline.  The 
Communications settings are automatically saved to the Windows Registry when DX 
Navigator is closed. 

• COM Port Sets up DX Navigator for either RS-232 or USB communications.  
The Com Port drop-down list displays the port numbers of all 
COM ports available on your computer.  For both RS-232 and 
USB communications, select from the list the port number to 
which the DX1208 is connected.  
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 Frequently you will see several COM ports listed.  Normally (but 
not always) the first few port numbers are reserved for RS-232 or 
other legacy serial device ports, while higher numbered ports 
represent the USB ports of devices already connected to the 
computer.  The DX1208 must be powered on and connected to a 
USB port on your computer before opening DX Navigator, or else 
its USB com port number will not appear in the COM Port list. 

 If you are not sure which COM port the DX1208 is connected to, 
open the Windows Device Manager, and locate ‘Ports (COM & 
LPT)’ in the list.  You will see ‘EAWC DX Family USB Serial Port’ 
followed by a COM port number.  Select this COM port number for 
USB communications, or the appropriate ‘Communications Port’ 
number for RS-232 communications. 

 Selecting the COM Port radio button restricts DX Navigator to 
communicating with only the device connected to the specified 
COM port, even if there are connected devices that would 
otherwise be visible to DX Navigator using a different 
communications protocol. 

• Obtain IP Addresses By Broadcast Sets up DX Navigator to communicate over 
a local/wide area network via Ethernet.  In this mode DX Navigator 
polls the network using by sending UDP (User Datagram Protocol) 
broadcast messages to TCP port 30718 looking for any DX 
devices connected to the network, regardless of whether they are 
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set for dynamic or static IP operation (see the IP section of this 
helpfile for information about configuring hardware IP settings).  
When a unit receives the UDP broadcast message it responds 
back with its IP Address and Device Name, and DX Navigator 
adds it to the Found Devices list in the Main Window.  Obtain IP 
Addresses By Broadcast works only when the DX Navigator 
computer and DX device(s) are on the same subnet. 

• Specify Target IP Addresses Sets up DX Navigator to communicate over a 
local/wide area network via Ethernet.  In contrast to Obtain IP 
Addresses By Broadcast, in this mode DX Navigator polls the 
network for only those units specified in the Target IP Addresses 
list.  All other DX units present on the network are excluded from 
polling. 

 

Using Specify Target IP Addresses requires that the DX devices 
represented in the list be assigned matching static IP addresses;   
dynamic IP addressing should never be used, because dynamic 
addresses can change after a device is powered up or its DHCP 
‘lease’ period expires. See the IP section of this helpfile for more 
information about using static and dynamic IP addresses. 

NOTE:  Using targeted IP addresses can solve network 
communication problems where UDP broadcast messages are 
blocked by computer OS and network device (routers, gateways) 
firewalls.  Specify Target IP Addresses mode does not use UDP 
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broadcasting, thus allowing DX Navigator to find DX devices 
within secured networks.  In most networks Specify Target IP 
Addresses should be used whenever the computer and DX 
device(s) are connected to different subnets. 

• Target IP Addresses When Specify Target IP Addresses is selected, DX 
Navigator polls only those units whose IP addresses are listed in 
the Target IP Addresses list.  DX units present on the network but 
whose IPs are excluded from this list are not polled, and therefore 
will not appear in the Found Devices list. 

• Add Adds the [IP Address] specified in the IP Address text box to the 
Target IP Addresses list. 

• Remove Removes the selected [IP Address] from the Target IP Addresses 
list. 

Going Online 
Description 
In order to control DX hardware devices you must go online.  Going online causes DX 
Navigator to communicate with all devices that are available through the selected 
Communications protocol, and list all devices it discovers in the Found Devices tab.  Once 
device(s) are found, DX Navigator continuously monitors the status of each device connection.  
Double-clicking the Device Icon of any online device then allows you to login to and open the 
unit’s Device Window. 
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Parameters 
• Go Online When Go Online is pressed, DX Navigator sends out a message 

using the selected communications protocol requesting that all DX 
devices receiving the message identify themselves to DX 
Navigator.  Devices respond by sending back their Device Name, 
IP Address (if Ethernet communications is selected), and device 
type.  Each device that responds is then listed in the Found 
Devices tab.  Devices that are powered on or connected after DX 
Navigator is online will also appear in the list (Ethernet 
communication only).  

Once DX Navigator is online, double-clicking the Device Icon of 
any online device in the list allows you to login to and control the 
unit through its own Device Window.  Pressing the Go Online 
button again takes DX Navigator offline, closes all open Device 
Windows, and removes all devices from the Found Devices list. 

NOTE:  In DX Navigator 1.0.0, the number of IP connections to 
any single DX device is limited to three instances of DX Navigator.   
Therefore if there are 4 or more concurrent instances of DX 
Navigator running on the network, the device will appear in the 
Found Devices list of only the first three instances of DX Navigator 
that connected to it.   This limitation will be removed in a later 
version of DX Navigator. 

• Identify When DX Navigator is online, pressing the Identify button causes 
the front panel LEDs of whatever device is selected in the Found 
Devices list to flash in a random pattern.  Devices must be online 
(indicated by green check mark) to be identified. Use this 
command to correlate DX devices to their corresponding Device 
Icons in the Found Devices list. 

 

• Refresh The Refresh command forces DX Navigator to reestablish a 
communication connection with the selected device, but without 
taking DX Navigator offline.  Use Refresh whenever the device 
Status Indicator turns to a red exclamation mark and you are 
confident he the problem that caused the communication 
disruption is resolved.  To use Refresh, first select the Device 
Icon of the desired device in the Found Devices list, then choose 
Refresh from the Edit or R-click popup menu. 
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Status Indicators 
When DX Navigator isonline, one of three symbols will appear in front of each Device Icon in 
the Found Devices list to indicate the current status of the device: 

•  The cycling arrows indicate that DX Navigator is establishing or 
refreshing a communications connection with the device.  When 
the device is in this state you cannot open its Device Window (by 
double-clicking the Device Icon), nor execute any commands from 
the R-click or Edit menus (except the Refresh command). 

•  The green check mark indicates that DX Navigator has 
established a communications connection with the device and that 
the device is online and available for use.  In this state you can 
login to the device and open its Design Window, identify devices, 
and use all applicable R-click and Edit menu commands. 

•  The red exclamation mark indicates that DX Navigator has lost the 
communications connection with the device.  DX Navigator 
continually monitors the communication connection to every 
device in the Found Devices list.  If a device fails to respond to a 
message from DX Navigator within a certain time period, then DX 
Navigator deems that the unit has gone offline and ‘drops’ the 
communication connection. 

The connection can be dropped for obvious reasons, such as a 
faulty comms cable or a device power failure, or not-so-obvious 
reasons, such as bandwidth limitations through a busy or clogged 
network.  When the device is in this state you cannot open its 
Device Window (by double-clicking the Device Icon), nor execute 
any commands from the R-click or Edit menus (except the 
Refresh command).  If the unit’s Device Window is open when it 
goes offline, then the Device Window’s Online Status indicator 
also turns red.  Use the Refresh command to reestablish 
communication with the device once the device comes back 
online (without taking DX Navigator offline). 

Logging In 
Description 
All DX series devices have built-in hardware-level security to prevent unauthorized users from 
controlling or changing device settings.  To access a unit’s Device Window you must first login 
to the device by either by double-clicking its Device Icon, or selecting its Device Icon and 
choosing Open from the Edit or R-click popup menu.  When the Password dialog opens, 
select the appropriate Permission Level from the drop-down list, and enter the corresponding 
Password for that Permission Level. 
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If the Password matches the value stored in the device, DX Navigator opens the unit’s Device 
Window.  By default the Admin and User Passwords are blank.  Therefore if the Password for 
a Permission Level is blank, simply clicking the Login button gives the user de facto 
permission for that selected Permission Level.   Renaming or editing the device settings (see 
Edit Operations) also requires you to login if you have not previously done so during the 
current DX Navigator session. 

NOTE: If you are a system administrator and desire to secure access to the hardware, then be 
sure to setup the Admin and User Passwords from the Device Window’s Settings tab after you 
first login to the device. 

Parameters 
• Permission Level Selects between [Admin] or [User] level access to the device.  

Administrative permission grants the user full access to the 
hardware through the Device Window.  User permission grants 
the user the ability only to load Presets, view the Event Log, and 
view the Input/Output Channel Strip through a highly abridged 
version of the Settings tab. 

• Password Admin and User Passwords may be up to 16 characters in length, 
contain any combination alphanumeric characters, and are case-
sensitive. 

Naming Devices 
Description 
Each DX device can be given a unique name which is stored in the device’s non-volatile 
memory.  Whenever DX Navigator establishes a communications connection with a device, it 
reads the device’s name and displays it in the Found Devices tab next to the unit’s Device 
Icon.  The Device Name also appears in the Title Bar of the unit’s Device Window.  By default 
the Device Name of all DX devices shipped from the factory are blank. 

Likewise, designs can also be given unique names.  Design Names are displayed in the Title 
Bar of Design Windows.  Dragging a Device Icon from the Device Library into the Design tab 
creates a design named “Untitled DX1208”; dragging a device from the Found Devices to the 
Design tab creates a design named “Copy of [Device Name]”.  To preserve the identity of 
devices and designs, names are not overwritten when one unit is dropped or pasted onto 
another (see Edit Operations). 

To rename a hardware device: 
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1. Go online with DX Navigator. 

2. In the Found Devices tab, select the device you wish to rename.  The device must be 
online (green check mark appears in front of Device Icon). 

3. Either <R+CLICK> on the Device Icon, or select Rename from the Edit or R-click 
popup menu. 

 

4. The Password dialog opens.  Login as an administrator. 

5. Type a name in the Rename Device dialog, and <CLICK> OK. 

 

 

Menu Commands 
• Rename Changes the name of either a hardware device (from the Found 

devices tab), or a device design (from the Design tab).  Names 
can be up to 32 alphanumeric characters; double quote and 
question mark characters are disallowed.  Device Names are 
stored in hardware memory, and are retained when the unit is 
power cycled.  Design Names are saved in Site Files. 

Device Designs 
Description 
With device designs (also referred to simply as ‘designs’), DX Navigator allows you to setup 
and configure DX devices offline.  By opening a generic Device Window for a particular device 
type, you can edit the device’s settings just as though you were controlling the hardware 
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directly.  Later, when you are online, you can upload the design settings to any device of the 
same type, and download hardware settings to new or existing designs. 

Designs are created in the Design tab.  The Design tab functions much like the Found Devices 
tab, except that Device Windows opened from the Design tab do not control hardware devices, 
as they do from the Found Devices tab.  Design Windows launched in the Design tab do not 
affect or interact with Design Windows launched from the Found Devices tab except when 
settings explicitly are copied from one to the other. 

Double-clicking a Device Icon in the Design tab opens a Device Window for the design.  
Because Permissions are hardware based, the Password dialog doesn’t appear.  The 
Permissions and Event Log controls are disabled in designs for the same reason.  The Design 
tab can hold any number of designs, and the contents of the Design tab can be archived to a 
Site File on your local hard drive. 

NOTE:  Designs do not presently support Presets.  Only the current Device Window settings 
can be saved to Site Files, and uploaded to/downloaded from hardware devices (see Edit 
Operations).  This will be corrected in a later version of DX Navigator. 

To create a new device design: 

1. <CLICK> the Device Library tab to bring it to the front. 

2. <CLICK+DRAG> the DX1208 Device Icon from the Device Library tab to the Design 
tab. 

3. A new DX1208 design appears in the Design tab.  The default Device Name for new 
design is “Unnamed [device type].” 

 

 12



You can also create copies of hardware devices by dragging Device Icons from the Found 
Devices tab into the Design tab.  This operation is covered in more detail under Edit 
Operations. 

To rename the design: 

1. In the Design tab, <CLICK> the device you wish to rename. 

2. Either <R+CLICK> on the Device Icon, or select Rename from the Edit or R-click 
popup menu.  Because designs do not control hardware, there is no need to go online or 
login as with renaming hardware devices from the Found Devices tab. 

3. Type a name in the Rename Device dialog, and <CLICK> OK. 

Site Files 
Description 
DX Navigator allows you to save the entire contents of the Design tab to a file on your 
computer’s hard drive.  By saving designs into Site Files, users can archive the settings of one 
or many DX series hardware devices to a single file on disk.  Conversely, by allowing you to 
work offline, users can setup or reconfigure or and entire DX system without having to be on 
site or have hardware connected.   

Site Files store every device design parameter setting (see Device Designs) for an unlimited 
number of designs present in the Devices tab. They can be created, saved, and opened 
without affecting the operation of online hardware devices.  Like Device Names, Site File 
names are reflected in the Title Bar of the Main Window.  Site Files have the extension ‘.DXN’ 
and can be saved to any directory on disk. 

Menu Commands 
The Site File commands are located under the File menu in the Main Window. 

• New Clears the contents of the Design tab and creates a new Site File.  
Launching DX Navigator creates a new Site File by default. 

• Open Opens the selected Site File, replacing the current contents of the 
Design tab with the contents of the Site File. 

• Save Stores the current contents of the Design tab to the named Site 
File.  Saving a new, untitled Site File opens the Save As dialog 
and prompts you to name the new file. 

• Save As Stores the current contents of the Design tab to a Site File with a 
prompt to rename the file.  The Main Window Title Bar changes to 
reflect the new name.  

• Recent File At the bottom of the File menu is s list of the four most recently 
opened Site Files.  Selecting any listed Site File opens the file. 

Edit Operations 
Description 
DX Navigator allows you to copy Device Window settings within and between the Design and 
Found Device tabs using keyboard shortcuts (e.g. CTRL+C for Copy, etc.) using commands 
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from the Edit and R-click pop-up menus, or dragging/dropping with the mouse.  The behavior 
of each edit operation differs slightly depending on the source and destination tabs.  For 
conciseness, the examples given below describe edit operations using only Edit menu 
commands and drag/drop operations.  

Found Devices Tab 
Within the Found Devices tab, device settings can only be copied from one hardware device to 
another; they cannot be cut or deleted as they can in the Design tab.   

To copy the settings from one device to another: 

1. <CLICK> the Found Devices tab to select it. 

2. With DX Navigator online, <CLICK> on the device whose settings you wish to copy. 

3. Select Copy from the Edit menu. 

4. <CLICK> the device whose settings you wish to overwrite and select Paste from the 
Edit menu. 

OR 

5. <CLICK+DRAG> the device whose settings you wish to copy and <DROP> it onto the 
device whose settings you wish to overwrite. 

 

6. The Password dialog opens (if you have not previously logged in during this session).  
Login as an administrator. 
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7. A dialog appears asking you to confirm the operation. <CLICK> the Copy Device to 
Device button. 

 

8. All of the current source device settings are written to the destination device EXCEPT for 
the Device Name and all Settings tab parameters (Presets, Permissions, IP settings, 
Event Log data, and Master/Slave).  DX Navigator refreshes the destination device 
connection as the new settings are read back. 

Design Tab 
Within the Design tab, settings can be copied from one design to another, and devices can be 
both created and deleted.  The method for copying one design onto another is identical to that 
described in the previous example, with the exception that you do not need to be online. 

To copy of an existing design to a new design: 

1. In the Design tab, <CLICK> on the design you wish to copy. 

2. Select Copy from the Edit menu. 

3. <CLICK> in an empty area of the Device tab to deselect the source design, and select 
Paste from the Edit menu. 

OR 

4. <CLICK+DRAG> the design whose settings you wish to copy and <DROP> it onto an 
empty area of the Device tab. 
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5. A new design named “Copy of [Design Name]” appears at the bottom of the list. All of 
the current source design settings are written to new design EXCEPT for Permissions, 
Event Log data, and Presets (see Note); the IP and Master/Slave settings are, however, 
copied to the new device. 

To delete a design: 

1. In the Design tab, <CLICK> on the device you wish to delete. 

2. Select Cut or Delete from the Edit menu, or press the <Delete> key.  Using the Cut 
command copies the selected device’s settings to the Windows clipboard (for 
subsequent Paste operations), whereas using the Delete command simply removes the 
design without affecting the contents of the clipboard. 

Found Devices + Design Tabs 
Between the two tabs, design settings can be uploaded to online hardware, and online 
hardware settings can be downloaded to designs.  The examples below illustrates the process 
of archiving and restoring the current settings of a hardware setup to/from a Site File.  While 
the upload/download operations are nearly identical, there are small differences between 
them, as noted in the example below. 

To archive a system to a Site File:  

1. In the Main Window, <CLICK> the File menu and select New.  The Design tab is 
cleared, and the Title Bar of the Main Window displays “Untitled.” 

2. Go online with DX Navigator. 
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3. In the Found Devices tab, <CLICK> on the first device that you wish to archive to select 
it. 

4. Select Copy from the Edit menu. 

5. <CLICK> in an empty area of the Design tab, and select Paste from the Edit menu. 

OR 

6. <CLICK+DRAG> the device whose settings you wish to archive and <DROP> it into an 
empty area of the Design tab.  All of the current hardware device settings are written to 
the design EXCEPT for Permissions, Event Log data, and Presets. 

7. A new design is created with the name “Copy of [Device Name].”  Repeat steps three 
through six for every device you wish to archive. 

 

 

8. If so desired, rename each of the designs to match the names of the hardware devices 
exactly. 

9. <CLICK> Save in the File Menu.  Enter a name for the Site File in the Save As dialog, 
and <CLICK> the Save button.  The Main Window Title Bar changes to reflect the new 
Site File name. 

To restore a system from a Site File: 

1. In the Main Window, select Open from the File menu. 
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2. From the Open dialog, navigate to and select the Site File you wish to open and 
<CLICK> the Open button.  The Design tab is cleared replaced with the designs stored 
in the Site File.  The Title Bar of the Main Window changes to reflect the name of the 
open Site File. 

3. Go online with DX Navigator. 

 

4. In the Design tab, <CLICK> on the first design that you wish to restore. 

5. Select Copy from the Edit menu. 

6. In the Found Devices tab, <CLICK> on the device you want to restore the copied 
settings to, and select Paste from the Edit menu. 

OR 

7. From the Design tab, <CLICK+DRAG> the first design you wish to restore and 
<DROP> it onto the device in the Found Devices tab you want to restore the settings to. 

8. If you have not yet logged in for this session, the Password dialog appears.  Login as an 
administrator. 

9. A dialog appears asking you to confirm the operation.  <CLICK> the Copy Design to 
Device button. 

 18



 

10. All of the current design settings are written to the destination device EXCEPT for the 
Device Name and all Settings tab parameters (Presets, Permissions, IP settings, Event 
Log data, and Master/Slave).  Note that IP settings are stored in the Site File for 
reference only.  Uploading a design to a hardware device does not overwrite the 
device’s IP settings to prevent network address conflicts arising from the same design 
being uploaded to multiple devices.  Instead, IP settings must be copied manually. 

Edit Menu Commands 
Except where noted below, the following Edit commands are available both from the Main 
Window File menu and the R-click popup menus. 

• Open Opens the Device Window of the selected design or hardware 
device.  A login is required for hardware devices the first time 
Device Windows are opened in a session. 

• Cut Deletes the selected design and places the design settings into 
the Windows Clipboard for subsequent use in Paste operations.  
Cut is available only from the Design tab.  [Keyboard Shortcut = 
CTRL+X]. 

• Copy Places a copy of the current design or hardware device settings 
onto the Windows Clipboard for subsequent use in Paste 
operations.  [Keyboard Shortcut = CTRL+C]. 

• Paste Overwrites the settings of the selected device/design with the 
settings placed into the Windows Clipboard via Cut or Copy.  
Pasting into an empty area of the Design tab creates a new 
design based on the contents of the Clipboard.  [Keyboard 
Shortcut = CTRL+V]. 

• Delete Removes the selected design from the Design tab, but does not 
copy the settings to the Windows Clipboard.  Delete is available 
only from the Design tab.  [Keyboard Shortcut = Delete]. 

• Properties Not implemented in DX Navigator v1.0.  Available only from the R-
click popup menu. 
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Menu Items 
Description 
This section describes Main Window menu items not described elsewhere in this helpfile. 

• File > Exit Closes DX Navigator and all open Device Windows. 

• View > Toolbar Hides and reveals the DX Navigator Toolbar for quick access to 
the following menu items: 

Menu Commands 
File  New, Open, Save  
Edit  Cut, Copy, Paste 
Help DX Navigator Help 

 

• Tools > Units Selects which unit format to select for distance and temperature 
parameters.  The Units setting does not currently affect any DX 
Navigator 1.0 parameters. 

[SI] Selects SI units (meters, Celsius). 
[US] Selects US units (feet, Fahrenheit). 

• Tools > PEQ Format Selects which format to use when displaying parametric 
EQ bandwidth. 

[Q] Displays bandwidth in Q (quality factor). 
[BW] Displays bandwidth in fractional octaves [BW = 

log(F2/F1)/log2]. 
• Help  > About Lists the installed version of DX Navigator software.  See 

Firmware Version for more information on obtaining the firmware 
version of hardware devices. 

 

Device Window - Overview 

Overview 
DX1208 parameters and controls are accessed through a DX1208 Device Window.  The 
Device Window groups related parameters and controls together and displays them on 
different tabs which appear (roughly) in the order of signal flow through the unit.  From left to 
right the tabs are: Input, Priorities, Automix, Output, DX Link, Logic IO, Remotes, and Settings. 
Each tab with its controls and parameters is described in its own section of the helpfile.  The 
DX1208 Device Window with the Input tab selected is shown below. 
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Common Controls 
A number of parameters and controls are common to all Device Window tabs. 

Parameters 

 

• Mute All Mutes all Input, Output, DX Link Input, and DX Link Output 
Channels. 

• Unmute All Unmutes all Input, Output, DX Link Input, and DX Link Output 
Channels. 

• Online Status When a unit is online the indicator in the upper right corner of the 
Device Window is green; when it is offline it is red.  The Online 
Status indicator is absent from Design Windows because Design 
Windows do not control hardware devices. 
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Input/Output Channel Strip 
The Input and Output Channel Meter, Gain, Mute, and Solo controls appear at the bottom of 
all tabs except the Automix tab.  These controls are described in the Input Section of this 
helpfile. 

Device Window – Input Tab 

Input Section 
Description 
The DX1208 has eight analog and four S/PDIF digital input channels.  Inputs 1-8 are balanced 
mic/line level inputs with a max peak input level of +24 dBu, each having switchable phantom 
power and adjustable preamplifier gain.  A second set of stereo unbalanced inputs parallels 
Inputs 5-8.  Each Input has a left and right side that are first summed to mono, then summed 
with the output of the mic/line preamplifier before A/D conversion.  These inputs have a max 
peak input level of +10 dBV, and have no analog gain control.  All Input Channels have digital 
Gain, Meter, Solo, and Mute controls which appear in the Channel Strip at the bottom of all 
Device Window tabs except the Automix tab. 

Parameters 
• Channel Select Selects the Input Channel that is controlled by the Input tab. 

• Channel Name Input Channels can be given a Channel Name of up to 32 
characters in length. 

• Mic Pre Controls the gain of the analog microphone preamplifier for 
balanced Inputs 1-8; Mic Pre gain can be set to [0], [+20], [+40], 
[+50], and [+60 dB].  Mic Pre gain does not affect unbalanced 
Inputs 5-8. 

• Phantom Applies P48 phantom power to the eight balanced Analog Input 
jacks. 

• Meter Displays the instantaneous peak signal level of the Input Channel 
after the analog microphone preamplifier, but before the Mute 
switch and Fader. 

• Fader / Gain Controls the digital (post A/D) gain of the Input Channel, prior to 
routing to the DSP processes.  Gain can be applied from [-99] to 
[+20 dB] in 0.1dB steps using the Gain textbox, or from [-38] to 
[+20] by dragging the Fader handle; dragging the Fader handle all 
the way to the bottom sets the Gain to [-99 dB].  <CTRL+CLICK> 
in the channel Meter to reset Gain to unity. 

• Mute Mutes the Input Channel.  The Mute is applied between the input 
Meter and Fader. 

• Solo Soloing an Input Channel mutes all Inputs that are not soloed; 
Soloing an Output Channel mutes all Outputs that are not soloed.  
However, Solos do not override existing Mutes, so any channel 
that is both muted and soloed will not be heard.  If both Input and 
Output Channels are soloed at the same time, make sure that all 
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Input Channels routed to the soloed Outputs are also soloed, or 
they will not be heard. 

Gate 
Description 
Each of the twelve DX1208 Input Channels is equipped with a Gate that occurs between the 
input Fader and the Compressor in the DX1208 signal chain.  Gates are designed to reduce or 
eliminate unwanted background noise from an input (typically a microphone input) when the 
source is not on-mic.  For example, in a theater production with many performers using 
wireless microphones, Gates may be employed on each actor to reduce the amount of stage 
noise picked up by the microphone when the actor is not speaking, thereby improving speech 
intelligibility and increasing the gain before feed back of the system.  Gates accomplish this 
task by effectively acting as volume-dependent mute switches: when the signal volume 
exceeds a defined threshold, then the gate ‘opens’ (is unmuted), and the signal passes 
unaffected.  When the volume drops below the threshold, the gate ‘closes’ and the gain is 
reduced by an amount defined by the depth setting.  Depth settings range anywhere from a 
few dB to -100 dB (equivalent to a hard mute).  The rate at which the gain is changed between 
unity and depth is determined by the attack and release settings.  The transfer curve of a 
DX1208 Gate with a Threshold of [-10] and a Depth of [20 dB] is shown below. 

 

Some commercial sound processors using gating techniques to perform automixing.  The 
DX1208 employs a different automixing technique based on gain-sharing.  Both techniques 
have their relative strengths and drawbacks.  However, when properly configured, the Gates 
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can be used in combination with the DX1208’s Automixer to increase the Automixer’s 
effectiveness.  See the Automixer section of this helpfile for more information. 

Parameters 
• Threshold When a channel’s signal level is below the Threshold setting, the gain is 

reduced by a fixed amount equal to the Depth setting.  When the signal 
level exceeds the Threshold, the gain is set to unity. 

• Attack Determines the rate at which the Gate increases gain from Depth to 
unity once the signal exceeds the Threshold.  The rate is determined by 
the formula (30 dB/[Attack]) dB/second. 

• Release Determines the rate at which the Gate decreases gain from unity to 
Depth once the signal falls below the Threshold.  The rate is determined 
by the formula (30 dB/[Attack]) dB/second. 

• Depth Specifies the amount of fixed gain reduction that is applied to the signal 
when the signal is below the Threshold. 

• Bypass Gate Bypasses the Gate without changing the Gate’s settings. 

Compressor 
Description 
Each of the twelve DX1208 Input Channels is equipped with a Compressor that occurs 
between the Gate and the 6-band EQ in the DX1208 signal chain.  Compressors are designed 
to reduce the dynamic range of signals for effective combination with other processor input 
sources, as well as optimize the processor output for the amplifiers, speakers, and SPL range 
of the listening environment. 

In typical sound reproduction systems, the dynamic range of most input sources, particularly 
microphones, is much greater than the system can allowably reproduce.  This is primarily 
because there are limits to both the minimum and maximum acceptable SPL level of the 
system, defined exclusively by the acoustical environment in which the system is installed.  
The loudest SPL that does not disturb the listeners defines maximum level, and the minimum 
level necessary to produce acceptable intelligibility above the ambient background noise 
defines the minimum level.  For example, in a popular music concert environment with a large 
audience and large PA system, this dynamic range may extend from 80 dBSPL to 115 dBSPL, for 
a working dynamic range of 35 dB.  In restaurants, boardrooms or other environments in which 
permanently installed commercial sound processors such as the DX1208 are deployed, the 
acceptable range may be only 15 to 25 dB, which is far less than a typical dynamic range of a 
microphone input, which may range from 30 to 80 dB or more.  The amplifier electronics and 
speaker transducers can also limit the overall dynamic range of the system, but in commercial 
applications these are usually less of a limiting factor than the acoustic environment. 

Compressors work by reducing the gain of a signal only when the signal exceeds a defined 
threshold level.  When the signal falls back below the threshold, the volume is returned to 
unity.  The amount of gain reduction is determined by a ratio control; the speed at which the 
compressor reacts to the signal is defined by the attack and release times.  Any overall gain 
loss from compression can be compensated for using a gain makeup control.  An example of a 
compressor input/output transfer curve is shown below. 
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Parameters 
• Threshold When a channel’s signal level exceeds the Threshold, the signal’s gain 

is reduced (i.e. compressed) by an amount determined by the Ratio.  
When the signal is below Threshold the gain is returned to unity (i.e. no 
gain reduction is applied).  The DX1208 Input Compressor uses a soft-
knee transfer curve to reduce the ‘pumping’ sound often heard with 
hard-knee compression.  With soft-knee compression gain reduction 
actually begins 3 dB below the Threshold.  The figure below illustrates 
the difference between a hard-knee curve (solid line) and a soft-knee 
curve with a Ratio of [20:1]. 

 

Inputs 9/10 and 11/12 employ true stereo compression: the energy sum 
of both the left and right inputs is applied to the threshold detector, and 
gain reduction is applied equally to both channels. 
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• Ratio Sets the aggressiveness of the Compressor by controlling the slope of 
the input/output transfer curve.  Once the signal exceeds the Threshold, 
the Ratio dictates the amount that the input volume must increase (in 
dB) to produce a 1 dB increase in output volume.  For example, with a 
[4:1] Ratio, a 12 dB increase in input volume produces a 3 dB increase 
in output volume. 

• Attack Determines the rate at which the Compressor reduces gain.  The rate is 
determined by the formula (15/[Attack]) dB/sec. 

• Release Determines the rate at which the Compressor increases gain.  The rate 
is determined by the formula (15/[Release]) dB/sec. 

• Gain Makeup Applies a fixed amount of gain boost at the output of the Compressor to 
makeup for loss in overall volume caused by high Ratio and/or low 
Threshold settings. 

• Bypass Compressor  Bypasses the Compressor/AGC without changing 
the Compressor’s settings. 

AGC 
Description 
The DX1208 Compressors can alternately function as an Automatic Gain Control (AGC).  
AGCs are designed to dynamically normalize the volume of an audio signal to a defined output 
level, regardless of the input signal level.  AGCs are used to ‘level’ out multiple program 
sources to roughly equalize their relative volumes or set their volumes in a predefined 
relationship.  For example the outputs from a TV, CD player, and radio may all be distributed 
through an overhead speaker system to patrons in a restaurant or bar.  The program level of 
the different TV stations, programs and songs will vary widely, but all need to be sent to the 
speakers at a relatively constant volume so that quiet material will not be drowned out by the 
background noise, and loud material will not be distracting:  When the program material is 
louder than the ‘target’ volume level, the AGC reduces the volume; when it is quieter than the 
target, it increases the volume. 

While the AGC retains some of the characteristics of a compressor, there are several key 
differences between an AGC and Compressor: 

• The rate at which an AGC makes its volume adjustments generally closely 
approximates the rate at which a human might adjust the volume of a source, and 
therefore program dynamics are preserved.  Compressors on the other hand are setup 
to act much faster and therefore will compress the dynamic range of the signal. 

• A compressor only reduces the gain of a signal.  An AGC both reduces the gain when 
the signal level is above the target, and increases the gain when it is below the target. 

• The AGC has a ‘gain hold’ function which prevents the volume from changing once the 
signal drops below a certain minimum level (usually called the silence threshold).  This 
prevents the AGC from increasing the volume during silence gaps in the program 
source (as is present in dialog, breaks between songs on a CD, etc.) 

Parameters 
• Target The Target specifies the ‘average’ output volume level of the source, 

and defines the unity gain point on the input/output transfer curve, as 
illustrated in the graph below.  When the source volume exceeds the 
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Target level, the gain is reduced; when it falls below the Target level it is 
increased, so that the output volume is always being driven towards the 
Target. 

• Threshold When the input volume exceeds the Threshold, the AGC is activated 
and makes dynamic volume adjustments that drive the output volume 
level towards the Target level.  When the input volume drops below the 
Threshold, the AGC stops adjusting the gain and holds it at the last set 
value.  The AGC is most effective when it makes volume adjustments 
only when a valid program source is present, but not when the source is 
absent.  DX Navigator limits the Threshold values to be ≤ the Target. 
For example, in a boardroom environment where multiple individuals 
each have their own microphone, every microphone will pick up the 
sound not only of the assigned speaker, but also background noise and 
the sound of every other speaker in the room.  To be effective, the AGC 
should act only on the speaker’s voice, but not act on the background 
noise.  Therefore set the Threshold just below the minimum volume 
level of the source to prevent the AGC from acting on background 
noise.  This prevents the AGC from making unwanted gain increases in 
the presence of background noise which will cause the source to be 
louder than desired when the source resumes.  For sources which 
slowly fade to silence (as may happen with subscription music feeds 
and CD music sources), set the Threshold approximately [10] to [15 dB] 
below the Target. 

• Attack Attack controls the rate of volume change (both increase and decrease) 
when the source volume exceeds the Threshold.  Attack settings will 
vary depending on the nature of the source, but generally should be set 
slower than the rates typically used with compression. 
With slow Attack times, very little AGC gain change will occur between 
when a gap/pause in the source occurs and when the source resumes.  
However, the AGC will not react as quickly to rapid increases or 
decreases in the program volume.  With faster Attack times the AGC 
will react more quickly to sudden changes in program volume, but 
greater gain changes will occur between silence gaps and the 
resumption of the source, potentially causing ‘pumping’ effects 
associated with compressors.  Set the Attack so that the volume change 
rate change sounds natural to the ear and does not draw attention to 
itself. 

• Ratio The AGC Ratio control determines the ratio at which the output volume 
increases with respect to the input volume, and in that respect is 
identical to the Compressor Ratio control.  The higher the Ratio, the 
less the output volume changes with for any given variance in input 
volume.  However, the input/output transfer curves of each differ with 
respect to how they intersect with the Threshold and Target values.  In 
the Compressor, the non-unity portion of the transfer curve passes 
through the Threshold; in the AGC, the non-unity portion passes 
through the Target.  The difference is illustrated by the graph below. 
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In practice the Ratio determines how aggressively the AGC tries to drive 
the output volume toward the Target.   

• AGC Enable Toggles the process between Compressor and AGC operation. 

• Bypass Compressor  Bypasses the AGC without changing the AGC’s settings. 

EQ 
Description 
Each of the twelve DX1208 Input Channels is equipped with a fully-configurable six-band EQ, 
which occurs in between the Compressor and the Ducker in the DX1208 signal chain.  Each 
EQ band can configured as a parametric, high/low pass, or shelving filter, and can be 
individually enabled or disabled. 

Parameters 
• Selected Determines which Filter the Type, Frequency, Gain, BW/Q, and 

Bypass Filter settings apply to. 

• Type Sets the Filter type of the Selected filter from amongst the 
following choices: [Parametric], [6dB Low shelf], [6dB High Shelf], 
[12dB Low Shelf], [12dB High Shelf], [12dB Low Pass], [12dB 
High Pass.] 

• Frequency Sets the Frequency center of the Selected Filter.  Frequency 
values range from [20 Hz] to [20 kHz]. 
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• Gain Sets the gain boost/cut of the Selected Parametric or Shelving 
Filter.  Gain values range from [+15 dB] to [-15 dB]. 

• Bandwidth / Q Sets the Bandwidth of the Selected Parametric Filter.  Setting the 
PEQ Format to [Q] in the Main DX Navigator > Tools menu lets 
you enter filter width as a ‘quality factor’ with values ranging from 
[0.25] to [10]; setting the PEQ Format to [BW] lets you enter 
Bandwidth in octaves with values ranging from [2.0] to [0.1].  The 
bandwidth of the Shelving and Hi/Low Pass Filters is fixed and 
cannot be changed. 

• Bypass Filter Bypasses the Selected Filter band without changing the Filter’s 
settings. 

• Bypass Channel EQ Bypasses all 6 Filter bands at the same time without 
changing any Filter’s settings. 

• Reset Channel EQ Resets all Filter parameters to their factory default settings. 
 

EQ Graph 
The response of the Input Channel EQ is plotted graphically (shown below).  The overall EQ 
response curve is shown with an orange line, and the response curves of individual Filters are 
shown with a yellow line. 

 

Selecting a Filter causes its response curve to appear in the graph; only one Filter’s curve is 
visible at a time.  Editing a band’s parameters changes both the overall and the individual 
Filter’s response curves, so that the contribution of the Filter to the overall EQ response can 
be easily observed.  Bypassing a Filter removes the individual Filter curve from the graph so 
that it cannot be edited graphically. 

Filters can also be edited directly from the EQ graph by dragging their Edit Handles on the 
screen.  To edit a Parametric Filter: 
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1. <CLICK> the square white Freq/Gain Handle to select the filter.  The previously selected 
Filter’s curve disappears, and the Selected Filter’s curve appears in yellow with a solid 
yellow Freq/Gain Handle. 

 

2. <DRAG> the Freq/Gain Handle up/down to adjust the Gain, and left/right to adjust the 
Frequency. 

3. <DRAG> the diamond shaped Bandwidth Handle left/right to adjust the filter’s Bandwidth. 

To edit a Shelving or Low / High Pass Filter: 

1.  <CLICK> the s-shaped white Freq Handle to select the Filter.  The previously selected 
Filter’s curve disappears, and the Selected Filter’s curve appears in yellow with a yellow 
Freq Handle. 

 

2. For Low/High Pass Filters (shown above), <DRAG> the yellow Freq Handle left/right to 
adjust the Frequency; for Shelving Filters <DRAG> the handle up/down to adjust the Gain, 
and left/right to adjust the Frequency. 

Ducker 
Description 
Each of the twelve DX1208 Inputs and 16 DX Link Inputs is equipped with a Ducker.  On the 
eight Input Channels the Ducker occurs in between the six-band EQ and the Matrix Mixer.  On 
the DX Link Inputs the Ducker occurs immediately after the DX Link Mute and Fader.  The 
Input tab contains only a subset of the Input Channel’s Ducker controls; the complete set of 
controls is found in the Ducker Priorities tab.  See the Priorities section of this helpfile for 
complete documentation on the Input and DX Link Duckers. 
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Device Window – Priorities Tab 

Ducker 
Description 
Each of the twelve DX1208 Inputs and 16 DX Link Inputs is equipped with a Ducker.  On the 
twelve Input Channels the Ducker occurs in between the six-band EQ and the Matrix Mixer.  
On the DX Link Inputs the Ducker occurs immediately after the DX Link Mute and Gain.  The 
Ducker is the only DSP process that is employed on the DX Link Input Channels. 

Duckers are designed to lower the volume of one or more input sources to allow one or more 
different input sources to be clearly heard.   Duckers are based on the concept of assigning a 
‘priority’ to each input, which describes how important it is for listeners to hear that source in 
relationship to all of the other sources.  Sources with a higher priority take precedence over 
sources with lower priorities.   The DX1208 Ducker supports 5 Priority levels with adjustable 
volume Depths for each.  Ducker Priorities can be triggered from Logic Inputs, Remotes, and 
from signals whose level exceeds a specified Threshold.  The rate at which the Ducker 
changes the volume during and after a priority trigger can also be adjusted. 

As an example of how a ducker might be used in practice, a typical airport may have many 
different sources that can be broadcast over the public address system, from background 
music, to airline representatives announcing flight boarding and departure information, to 
airport management issuing public service messages, and finally to public officials making 
airport-wide emergency safety and security alerts.  The background music channel is the least 
important source and is assigned the lowest priority, while the safety and security channel is 
the most important and is assigned the highest priority.  When an airline representative makes 
a boarding announcement, the music is ‘ducked’ in volume so that the representative can be 
heard over the music, but if a security announcement is broadcast at the same time the airline 
rep is making a boarding call, both the music and the representative will be ‘ducked’ so that 
only the security announcement can be heard. 

The Priorities tab contains all of the parameters for the Input Channel Duckers, which are 
shown below. 
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Parameters 
• Priority The DX1208 has five Priority levels, numbered [1] through [5].  

Channels with a higher Priority take precedence over channels of a 
lower Priority. When a Priority level is triggered, the gain of lower-
Priority channels is reduced (ducked), while the gain of channels with 
the same or higher Priority remains unchanged.  For example, channels 
set to Priority [1] cannot be ducked by any means; channels set to 
Priority [3] can be ducked by Priority [1] and [2] triggers, but not [3] 
through [5] triggers. 

• Level Detect Ducker activity can be triggered externally by a Remote Control or Logic 
Input signal, or internally by a channel’s signal level.  When Level 
Detect is [Enabled], a channel’s signal level will trigger ducking on lower 
Priority channels when its signal level at the EQ output (see the signal 
flow diagram in the DX1208 Instruction Manual) exceeds the Threshold 
setting.  When Level Detect is [Disabled], a channel’s signal cannot 
trigger ducking based on its signal level. 

• Depth When a Ducker priority trigger event occurs, all channels that are both 
assigned to a lower Priority level and are not Bypassed are reduced in 
gain by the amount set by the Depth control.  If multiple Priority levels 
are triggered simultaneously, then all levels below the lowest activated 
Priority will be ducked using the largest Depth setting amongst the 
triggered levels.   For example, if Priority [1] and Priority [3] are 
triggered at the same time, then all channels assigned to Priority [2] and 
[3] will be lowered in gain (in dB) by the Depth 1 setting, and all 
channels assigned to Priority [4] and [5] would be lowered in gain by the 
larger of the Depth 1 or Depth 3 settings. 

• Bypass When [Enabled], the Bypass control disables ducking on that channel.  
Bypassed channels can neither trigger ducking on other channels 
(through level detection), nor can they be ducked. 

• Threshold When Level Detect is enabled on a channel and its signal level exceeds 
the Threshold, then all channels with a lower Priority (that are also not 
Bypassed) are ducked. 

• Attack Controls the Ducker gain reduction rate (15 dB per Attack period) once 
a priority trigger event occurs.  Set the Attack rate so that the ducked 
channels reach depth quickly enough to avoid interfering with the 
priority channel(s), but without sounding too abrupt.  Avoid using a slow 
Attack with large Depth settings, because the Ducker may not reach 
depth before the priority source commences.  This is especially true 
when both the trigger event length and Hold times are short. 

• Release Controls the Ducker gain increase rate (15 dB per Release period) once 
the hold timer expires.  Set the Release rate so that the ducked 
channel(s) return to normal volume at a rate which sounds natural and 
is not distracting.  A natural-sounding Release rate is typically longer 
than a natural-sounding Attack rate. 

• Hold The Hold setting determines the length of the hold period, which begins 
when the priority trigger ends.  When the hold period begins the Ducker 
stops changing gain, and when the hold period expires, the Ducker 
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release begins.  Therefore if the priority trigger duration is longer than 
the Attack time, then the Ducker will reach depth before the trigger ends 
and then hold gain at depth for the duration of the hold period.  If the 
trigger is shorter than the Attack, then gain will not reach depth when 
the trigger ends, and the gain will be held at this value for the duration 
of the hold period.  The relationship between priority trigger event length 
and the Attack, Hold, Release, and Depth parameters is illustrated in 
the graph below. 

Using the example from the graph, if a level-detected signal crosses 
and remains above the Threshold for [300 ms], and the Attack is set to 
[200 ms], the Release to [600 ms], the Hold to [600 ms], and the Depth 
to [-30 dB], then gain is reduced by only -22.5 dB before the hold period 
begins.  However, if the signal remains above Threshold for [400ms], 
the gain reduction would reach depth before the hold period begins. 

 

Device Window – Automix Tab 

Matrix Mixer 
Description 
The DX1208 contains a 28x24 Matrix Mixer that allows any of the unit’s 12 Analog/Digital and 
16 DX Link Inputs to be independently assigned and mixed to any of its 8 Analog and 16 DX 
Link Outputs.  Additionally, the Matrix Mixers have independently functioning Automixers for 
each of the 8 Analog outputs; any Input assigned to an analog Output Channel can be 
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assigned to the Matrix with or without automixing applied.  The Matrix Mixer and the Automixer 
controls both share the Automix tab, as shown below. 

 

Signals arrive at the Matrix inputs post-Ducker and are seen immediately by the channel 
Meters before being routed through the Enable switch and the Fader (see the signal flow 
diagram in the DX1208 Instruction Manual).  The Input Channnel Fader controls the input’s 
gain to both the Matrix Master Output, and the Automixer input (if Automix is [On]).  All 
[Enabled] input channels are then summed before being routed to the Master Output Enable 
switch and Fader.  The Master Output Meter is post-Fader. 

Typical uses for a matrix mixer include creating independent mixes of the same source 
material for different areas, or zones, within a facility.  When combined with automixing, a 
matrix mixer may be used to setup mixes for clusters of speakers in which open microphones 
in close proximity to the cluster(s) are lower in volume than in those clusters which are farthest 
away from the microphones, as in a boardroom or conference facility. 

Input Channel Parameters 
• Enable Assigns the Input Channel to the selected Matrix Output.  When a 

channel is [Disabled], none of that channel’s signal is routed to the 
output, regardless of the channel Fader setting, and regardless of 
whether Automix is [On]. 

• Fader / Gain Controls the gain of the Input Channel to both the Matrix Mixer 
and the Automixer.  Adjust the gain by dragging the fader handle 
(from [+20] to [-39 dB]).  <CTRL+CLICK> in the channel Meter to 
reset the Fader to unity. 

 34



• Meter Displays the instantaneous peak signal level of the Input Channel, 
pre-Fader and pre-Enable. 

 

Master Output Parameters 
• Channel Select Selects the Matrix Output Channel that is controlled by the 

Automixer tab. 

• Enable Enables the Matrix Output.  When [Disabled], no audio passes to 
the Output Channel. 

• Fader / Gain Controls the overall gain of the Matrix Output.  Adjust the gain 
either by dragging the fader handle or entering a value (from [+20] 
to [-99 dB]) into the text box to the right of the Output.  
<CTRL+CLICK> in the Master Output Meter to reset the Fader to 
unity. 

• Meter Displays the instantaneous peak volume level of the Matrix 
Output, post-Fader and post-Enable. 

• Current Automix Level This text box displays the gain (in dB) of the last Matrix 
Channel whose Fader was adjusted. 

Automixer 
Description 
Automixers are designed to emulate a skilled human operator using a traditional mixing 
console to mix multiple speech inputs together.  Typical multi-source speech environments, 
such as are found in boardrooms, courthouses and city council chambers, conference 
facilities, and even theaters, present numerous challenges to both human and automatic 
mixers.  Speech intelligibility suffers when unused microphones pick up reverberance and 
unwanted room noise.  Additionally, increasing the number of open microphones decreases 
the overall system gain before feedback, making it harder in larger systems to apply sufficient 
gain to make the on-mic sources audible.   The fast pace of unscripted dialog exchange also 
makes it exceedingly difficult to anticipate when gain changes are required, and can lead to 
speakers’ words or sentences being cutoff before the operator can react. 

There are two types of automixers commonly used today: gain sharing, and gating automixers.  
Gating automixers use noise gates on each automix channel that open and close when a user-
defined threshold is exceeded.  With this method the number of microphones can change from 
moment to moment, and for this reason the more sophisticated gating automixers allow you 
limit the number of open microphones (NOM) to prevent feedback.  While gating automixers 
are good in certain applications, in general they are harder to setup (especially with larger 
systems), and the gating effects can sometimes be heard both on individual channels and in 
the overall system as background noise is modulated with the NOM. 

The DX1208 employs a gain sharing automixer, which works on the basis of expanders, rather 
than gates.  Instead of each microphone being turned on or off, all microphones are on all the 
time, and the overall system gain is distributed amongst them.  As one source gets louder with 
respect to the other sources, it receives a proportionately larger share of the overall gain; as 
another gets quieter, it receives a proportionally smaller share of the gain.  The advantage of 
this is that it is easy to optimize the system for maximum gain before feedback, especially in 
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larger systems, because the overall output gain remains constant for a given number of 
automix-enabled inputs.  And because the overall gain remains the same and microphones 
are never ‘off’, gating automixers do not have problems with background noise modulation and 
gate ‘chattering’, and are therefore in general more sonically transparent than gating 
automixers.  Both automixer types are superior to human operators in their ability to react 
quickly to input level changes. 

The DX1208 Automixer also measures signal correlation across all assigned inputs.  
Therefore when signal cancellation occurs between one or more inputs, the cancellation is 
factored into the gain-sharing calculations so that the gain reduction is appropriately weighted 
towards the input(s) that are contributing to the energy of the Automixer output signal.  
Correlation is not measured across Automixers; each Output Channel’s Automixer functions 
independently of the other.  

In DX Navigator v1.0, automixing is not available on the DX Link Matrix Outputs. 

Parameters 
• Automix On/Off Automix On/Off enables automixing for an individual input 

channel.  When set to [Off], the channel is not included in the 
automix gain calculations, and no automix gain is applied to it.  
When [On], the channel is both included in the automix gain 
calculations, and automix gain is applied to it. 

• Enable Automix Enable Automix enables automixing for the selected Matrix Output 
Channel.  When [Disabled], then no automix gain reduction is 
applied to any channel assigned to that Automixer. 

•    GR Meter Displays the amount of automix gain reduction applied to an Input 
Channel whose Automix On/Off is [On]; the GR Meter is inactive 
when Automix On/Off is [Off].  The maximum Automixer gain 
reduction is limited to -36db. 

• Ratio The Ratio setting controls the slope of the Automixer expander.  
With a Ratio of [1.0], the slope of the transfer curve is at unity 
(1:1), and the Automixer has no effect.  As the Ratio increases, 
the relative gain changes distributed amongst the channels 
become more and more pronounced.  The amount of gain 
reduction applied to each channel can be calculated based on 
adding a duplicate set of inputs to the Automixer.  As an example, 
with a single 0 dB sine tone applied to Matrix Input 1, no gain 
reduction is applied.  Adding an identical tone to Matrix Input 2 
causes both channels’ gain to be reduced 3 dB with a Ratio 
setting of [1.5], 6 dB with [2.0], 9 dB with [2.5], and 12 dB with 
[3.0].  Adding two more identical tones to Matrix Inputs 3 and 4 
causes the same amount of gain reduction again, and so forth. 

• Response Time Controls the rate at which the Automixer changes the gain (30 dB 
per Response Time period) of all automix-enabled channels.  This 
rate is identical for both the attack (gain reduction) and release 
(gain increase) portions of the Automixer response. 
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Device Window – Output Tab 

Output Section 
Description 
The DX1208 has eight balanced, line-level Analog Output Channels having a max peak output 
level of +24 dBu.  All Output Channels have digital Gain, Meter, Solo, and Mute controls which 
appear in the Channel Strip at the bottom of all Device Window tabs except the Automix tab. 

Parameters 
• Channel Select Selects the Output Channel that is controlled by the Output tab. 

• Channel Name Output Channels can be given a Channel Name of up to 32 
characters in length. 

• Meter Displays the instantaneous peak signal level of the Output 
channel immediately prior to the output D/A converter. 

• Fader / Gain Controls the gain of the Output Channel after the Crossover and 
Mute switch, but prior to the Limiter and Delay.  Gain can be 
applied from [-99] to [+20 dB] in [0.1 dB] steps using the Gain 
textbox, or from [-38] to [+20 dB] by dragging the Fader handle; 
dragging the Fader handle all the way to the bottom sets the Gain 
to [-99 dB].  <CTRL+CLICK> in the channel Meter to reset Gain 
to unity. 

• Mute Mutes the Output Channel.  The Mute is applied between the 
Crossover and the Fader. 

• Solo Soloing an Output Channel mutes all Outputs that are not Soloed; 
Soloing an Input Channel mutes all Inputs that are not Soloed.  
However, Solos do not override existing Mutes, so any channel 
that is both Muted and Soloed will not be heard.  If both Input and 
Output Channels are Soled at the same time, make sure that all 
Input Channels routed to the Soloed Outputs are also Soloed, or 
they will not be heard. 

EQ 
Description 
Each of the eight DX1208 Output Channels is equipped with a fully-configurable eight-band 
EQ, which occurs in between the Matrix Mixer Output and the Channel Crossover Filters in the 
DX1208 signal chain.  Each EQ band can configured as a Parametric, High/Low Pass, or 
Shelving Filter, and can be individually enabled or disabled. 

These Filters are functionally identical to the Input Channel Filters described in the Input EQ 
section of this helpfile.  Those Output Channel EQ controls that differ from their Input Channel 
EQ counterparts are described below. 

Parameters 
• Parametric EQ Bypassed Bypasses all eight Filter bands at the same time without 

changing any Filter’s settings. , disabling the entire EQ while 
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preserving each filter’s settings.  The two Crossover Filters remain 
unaffected. 

• Reset Parametric EQ Resets all eight Filter parameters to their factory default 
settings.  The two Crossover Filters remain unaffected. 

Crossovers 
Description 
Each of the eight DX1208 Output Channels is additionally equipped with a pair of Low- and 
High-Pass Crossover Filters that occur between the Output Filters and the Limiter in the 
DX1208 signal chain.  Each Crossover Filter can be set to any of three standard crossover 
filter types – Butterworth, Bessel, and Linkwitz-Riley – and adjustable slopes of 6, 12, 18, or 24 
dB/octave. 

Parameters 
• Selected Determines which Filter the Type, Frequency, Gain, and BW/Q, 

and Bypass Filter settings apply to.  When a Crossover Filter is 
Selected, the Gain and Bandwith controls are disabled. 

• Type When a Crossover Filter is Selected, Type sets the Filter type 
from amongst the following choices: [6 dB], [12 dB Butterworth], 
[12 dB Bessel], [12 dB Linkwitz-Riley], [18 dB Butterworth], [18 dB 
Bessel], [24 dB Butterworth], [24 dB Bessel], [24 dB Linkwitz-
Riley].   
Note: The [6 dB Butterworth] and [6 dB Bessel] filter responses 
are identical.  Therefore only a single 6 dB filter type is presented. 

• Frequency Sets the Frequency center of the Selected Filter.  Frequency 
values range from [20 Hz] to [20 kHz]. 

• Bypass Filter Bypasses the Selected Crossover Filter band without changing 
any of the Filter’s settings. 

• Gain Disabled when a Crossover Filter is Selected. 

• Bandwidth / Q Disabled when a Crossover Filter is Selected. 
 

EQ Graph 
The response of the Crossover Filters is plotted along with the response curves of the eight 
Output Channel Filters.  A general description of the EQ Graph and how to edit EQ 
parameters graphically can be found in the Input EQ section of this helpfile. 
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To edit a Crossover filter from the EQ graph: 

1. <CLICK> the diagonal white Frequency Handle to select the Crossover.  The previously 
selected Filter’s curve disappears, and the Selected Crossover’s curve appears in yellow 
with a solid yellow Frequency Handle. 

 

2. <DRAG> the Frequency Handle left/right to adjust the Frequency. 

Limiter 
Description 
Each of the eight DX1208 Output Channels is equipped with a Limiter that occurs between the 
Output Fader and the Delay in the DX1208 signal chain.  The Output Channel Limiter is in all 
respects identical to the Input Channel Compressor (see the Input Channel Compressor 
section of this helpfile), with two small differences.  First, the Limiter uses a hard-knee transfer 
curve, while the Compressor uses a soft-knee transfer curve.  Second, the Limiter allows an 
[Infinite:1] Ratio, while the Compressor is limited to a maximum Ratio of [20:1]. 
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In general the difference between compressors and limiters lies principally in the way they are 
configured and used rather than how the DSP processes actually function.  Compressors are 
traditionally used to reduce the dynamic range of signals to within a nominal range that is 
compatible with the acceptable dynamic range of the entire sound reproduction chain 
(including amplifiers and speakers) within the context of the acoustic environment in which 
they are placed.  Compressors generally have lower ratios (i.e. less than 4), and thresholds 
set blow or near the nominal signal level of the system. 

Limiters, on the other hand, are used to place a limit on the maximum peak level of a signal in 
order to prevent clipping (in the analog or digital domain), or to protect downstream devices 
such as amplifiers and speakers from damage due to clipping and/or driving components 
above their rated maximum operating levels.  Therefore limiters typical use extremely high 
ratios (from 10 to Infinity) to prevent the signal from exceeding the absolute limit set by the 
threshold, thresholds at or near signal clip levels, and fast attack times to quickly suppress 
transient overloads.  They also use hard-knee compression so that signals can get as close to 
the threshold as possible before gain reduction is applied (which adds THD when very fast 
attack and release times are used.) 

The DX1208 gives you the flexibility to configure the Output Limiter as a Limiter, Compressor, 
or AGC.  Because the Limiter occurs AFTER the Output Fader, the DX1208 Limiter prevents 
amplifier overload caused by any other gain stage in the DX1208 Output.  How you decide to 
use the Output Limiter is completely dependent on your application. 

AGC 
Description 
As with the Input Channel Compressors, the Output Channel Limiters can also function as 
Automatic Gain Controls (AGC).  See the Input Channel AGC section of this helpfile for 
information on the Output Channel AGCs. 

Delay 
Description 
Each of the eight DX1208 Output Channels is equipped with a digital Delay that occurs 
between the Limiter and the D/A converters in the DX1208 signal chain.  Delays can be used 
to time-align individual drivers within a speaker system (used in combination with the 
Crossover Filters), or an array of distributed speakers so that sounds from each speaker arrive 
at the same time within a designated listening area. 

 

Parameters 
• Delay Output Channels can be individually delayed in single-sample 

increments (1 sample = 20.83 µs at 48 kHz), up to [2000 ms]. 
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• Bypass Delay Sets the effective channel delay to [0 ms], regardless of the Delay 
time setting. 

Device Window – DX Link Tab 
Description 
The DX1208 can simultaneously transmit and receive 16 channels of digital audio to/from 
other DX Link enabled devices via its DX Link Tx (transmit) and Rx (receive) jacks.   DX Link 
audio received from an upstream device is first routed to the Fader and Mute controls located 
in the DX Link tab, where they are labeled IDX 1 through IDX 16.  The IDX Channels are then 
routed through the Ducker, and then to the Matrix Mixer, where each channel can be mixed 
with the rear-panel Analog and Digital Inputs and routed to any combination of DX Link and 
rear-panel Outputs.  Because DX Link Input Channels have no DSP processing except 
Ducking, IDX Channels do not appear anywhere on the Input tab. 

DX Link Output (ODX) Channels originate with the Matrix Mixers located in the Automix tab.  
Any combination of rear-panel and IDX Channels can be mixed together in the Matrix.  From 
the ODX Matrix Outputs the signals are routed to the Fader and Mute controls in the DX Link 
tab, where they are labeled ODX 1 through ODX 16.  They are then routed directly to the DX 
Link Tx jack where they are transmitted to a downstream device.  Because DX Link Output 
Channels have no DSP they do not appear anywhere on the Output tab. 

When multiple DX1208 units are connected via DX Link, their sample clocks must be 
synchronized to a common master clock source.  See DX Link Clocking in the Settings tab for 
information on configuring the software to work with DX Link.   

NOTE:  DX Link is a proprietary EAW digital audio format that carries only digital audio and 
clocking data.  Though DX Link uses or network cable with RJ-45 connectors, it does 
not conform to the Ethernet physical or data layer standards, and therefore is not is 
not compatible with CobraNet® and other AoE (audio over Ethernet) formats.  DX 
Link connections must be made directly between DX1208 units without the use of 
intervening networking hardware such as switches, hubs, or routers. 

 

Parameters 
The controls for both the DX Link Inputs and Outputs are identical. 
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• Meter Displays the instantaneous peak signal levels of IDX Channels at 
the DX Link Rx (input) jack, pre-IDX Fader and Mute, and the 
instantaneous peak signal levels ODX Channels immediately prior 
to the DX Link Tx (output) jack, post-ODX Fader and Mute. 

• Fader / Gain Adjusts the Gain of IDX/ODX Channel.  IDX Faders occurs after 
the IDX Mute, but before the Ducker in the IDX signal path.  ODX 
Faders occur after the ODX Mute, but before the DX Link Tx jack 
in the ODX signal path.  Gain can be adjusted from [-40] to [+20 
dB] in 1 dB steps.  Adjust the Gain by dragging the Fader handle.  
<CTRL+CLICK> in the channel Meter to reset the Fader to unity. 

• Mute Mutes the IDX/ODX Channel.  IDX Mutes are applied between the 
DX link Rx jack and the IDX Fader; ODX Mutes are applied 
between the Matrix Master Output Fader and the ODX Fader. 

Device Window – Logic I/O Tab 

Logic Inputs 
Principle of Operation 
The DX1208 has six Logic Inputs that can each be assigned to control or trigger different 
functions within the unit, such as recalling Presets or muting channels.  The Logic Inputs are 
internally pulled high to +3.3V through a 10 kohm resistor, and can be activated directly by 
switch or relay closure, or driven by a TTL/CMOS open-collector Logic Output capable of 
sinking at least 0.35 mA of current.  Momentary contact switches are preferred, as latching 
switches state can easily get ‘out of sync’ with the overall state of the system. 

Logic Inputs can be set to either momentary or latching operation, and can trigger on a low-to-
high, or a high-to-low input signal transition.  Momentary triggers require only a single 
transition, and latching triggers require two transitions.  For example, if a normally-open 
momentary contact switch is connected to a Logic Input that is configured to momentarily mute 
channel 1 on a low transition, then channel 1 will be muted only as long as the switch is 
pressed and held; if the input is configured for latching operation, then channel 1 will remain 
muted after the switch is pressed and released.  Pressing the switch a second time unmutes 
channel 1.  Additionally, functions can never be triggered simply by changing a Logic Input 
setting, even if the change would otherwise cause the trigger to occur.  To use the previous 
example, if the user changes the Action from [Low] to [High] with the switch open (and hence 
the input is logic high from the pull-up resistor), a trigger does not occur, even though the logic 
condition matches the input condition. 
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Parameters 
• Name Each Logic Input can be given a Name to identify its function or 

location. 

• Enable When Enable is checked, a Logic Input can trigger the action 
defined by the Function setting.    

• State When the Logic Input meets the condition determined by the 
Active setting, the Logic Input becomes TRUE, and when it does 
not meet the condition it becomes FALSE.  However, how the 
Function is activated or deactivated depends on whether the 
Action is [Latching] or [Momentary].   The State indicator lights 
when the Function is active, rather than when the Logic Input is 
TRUE. 

• Action The Action setting determines whether the input remains active 
after the trigger signal becomes FALSE. 

[Momentary] With [Momentary] inputs the Function is activated 
when the input is TRUE, and deactivated when the 
input is FALSE. 

[Latching] With [Latching] inputs the Function is activated when 
the input becomes TRUE, and deactivated when the 
input becomes FALSE and then TRUE a second 
time. 

• Active Defines the logic state required to trigger the logic Function. 

[Low] The Function is triggered when the Logic Input sees 
a high-to-low transition. 

[High] The Function is triggered when the Logic Input sees 
a low-to-high transition. 

• Function Defines which DX1208 parameter(s) the Logic Input controls. 

[None] Disables the Logic Input.  Does the same thing as 
unchecking the Enable setting. 
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[Preset] Recalls the preset number chosen in the associated 
Select setting. 

[Priority] Triggers the ducker Priority level chosen in the 
associated Select setting. 

[Mute All In] Mutes and unmutes all Analog, Digital, and DX Link 
Inputs. 

[Mute All Out] Mutes and unmutes all Analog and DX Link 
Outputs. 

[Mute Ch] Mutes and unmutes only the Input, Output, or DX 
Link channel chosen in the associated Select setting. 

• Select Assigns a specific Preset, Priority level, or input/output channel 
number to the [Preset], [Priority] or [Mute Ch] Function. 

Logic Outputs 
Principle of Operation 
The DX1208 has three Logic Outputs which indicate various hardware conditions.  The Logic 
Outputs are open-collector outputs that are pulled high internally to +5V through a 340 ohm 
resistor.  They can sink up to 12 mA of current and drive an LED directly. 

Logic Outputs can be set active high (4.8V, unloaded) or active low (0.4V, unloaded). When a 
Logic Output is inactive, the output is set to the opposite logic level.  This is also true when the 
output Enable is unchecked or the Function is set to [None].   So, for example, if Function is 
set to [None] and Active is set to [Low], then the output will be high. 

 

Parameters 
• Name Each Logic Output can be given a Name to identify its function or 

location. 

• Enable When Enable is checked, then when condition defined by the 
Function setting occurs, the Logic Output becomes active. 

• State This indicator lights when the Logic Output is active, and is dim 
when inactive. 

• Active Active defines the logic level of the output when the output is 
active. 

[Low] When [Low], the Logic Output level is +0.4V 
(unloaded). 
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[High] When [High], the Logic Output level is +4.8V 
(unloaded). 

• Function Function defines which DX1208 parameter(s) the Logic Output 
controls. 

[None] Disables the logic output.  Does the same thing as 
unchecking the Enable setting. 

[System Normal] Indicates that the unit is operating normally.  
This condition is the inverse of the [System 
Failure] state. 

[System Failure] Indicates that some internal condition has 
caused the unit to reset itself.  This condition remains 
TRUE after the reset until the unit is power cycled.  
This state is the inverse of the [System Normal] state. 

[Comm Any]  This output represents the logical OR of all five of 
the comm logic outputs listed below:  [Comm Logic], 
[Comm Remotes], [Comm Ethernet], [Comm UART], 
and [Comm USB].  It is identical to the green COMM 
led on the unit’s front panel. 

[Comm Logic] This output is active whenever a high-low or low-
high transition is detected on any of the 6 logic 
inputs.  This is true regardless of whether the Logic 
Inputis Enabled, and regardless of which Function 
and Active states are defined. 

[Comm Remote] This output is active whenever communication 
is received from an Enabled remote control, and 
regardless of which Functions and Actions are 
assigned to the remote(s). 

[Comm Ethernet] Active when communication occurs between 
DX Navigator and the DX1208 hardware over the 
Ethernet port. 

[Comm UART] Active when communication occurs between DX 
Navigator and the DX1208 hardware over the RS-
232 port. 

[Comm USB] Active when communication occurs between DX 
Navigator and the DX1208 hardware over the USB 
port. 

 NOTE:  Since the [Comm Ethernet], [Comm UART], 
and [Comm USB] functions each indicate active 
communication connections with DX Navigator over 
their respective ports, activity on more than one of 
these Functions indicates that multiple instances of 
DX Navigator are connected to the unit. 

[DX Link Lock] Active when a synchronous DX Link signal is 
present on the DX Link Rx jack.  This output is 
identical to the DX Link Locked indicator in the UI 
Settings tab, and the DX Link Active led on the front 
panel of the unit. 
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[Enable Priority] Active when the Selected ducker [Priority] level is 
triggered by either a Logic Inputor a remote control; 
priority levels triggered by level detection are not 
indicated by this output. 

[Mute All In] Active when all physical and DX Link inputs are 
muted. 

[Mute All Out] Active when all physical and DX Link outputs are 
muted. 

[Mute Ch] Active when the Selected input or output channel is 
muted. 

• Select Select assigns a specific Priority level or Input/Output Channel 
number to the [Enable Priority] or [Mute Ch] Function. 

Device Window – Remotes Tab 
Description 
The DX1208 supports the use of external Remote Controls which can be used to control 
different DX1208 functions, such as recalling Presets, triggering ducker Priorities, or changing 
Input or Output Channel Gains.  The DX1208 communicates to the Remotes through a single 
RS-485 port on the rear of the unit that can directly power up to 10 Remote Controls.  An 
external power supply is required to connect more than 10 Remotes (see the Universal 
Remote Control - Quick Start Guide for more information). 

Every Remote connected to a DX1208 must be set to a unique bus address (up to 128 
addresses are possible).  It is not necessary to maintain unique addresses across multiple 
DX1208 units in a system, since each DX1208 is aware only of the Remotes connected to its 
own Remote Bus.  When the DX1208 powers up it queries the Remote Bus for the presence 
of Remotes at each of the 128 possible addresses.  If it finds a Remote, the DX1208 flashes 
the Remote’s LEDs to indicate that it has been found.  Remotes must be connected to the 
DX1208 at power up to be recognized and function properly.  The DX1208 will not recognize a 
Remote that is connected after power up. 

There are three types of DX Remote Controls: 

• UR-1 The UR-1 has a rotary encoder which controls the Gain of Input or 
Output Channels.  A ring of 15 LEDs surrounding the encoder 
displays the channel gain.  It also has a single function button that 
can be programmed for the same actions as the Logic Inputs.  
When the assigned Button Function is activated, the button’s LED 
lights. 

• UR-2 The UR-2 has four function buttons which can each be 
programmed for the same actions as the Logic Inputs.  When the 
assigned Button Function is activated, the button’s LED lights. 

• UR-3 The UR-3 is actually a UR-1 and UR-2 grouped together on the 
same wall plate.  As such they must be programmed as two 
individual Remotes. 

The Remotes tab is used to add and configure Remote Controls.  All Remote tab settings are 
stored in non-volatile hardware memory and are therefore retained when a unit is power 

 46



cycled.  They cannot be stored into or loaded from a Preset, but can be saved into a DXN file, 
or copied from one design/device to another. 

A list of all Remotes with their Names, Types, and IDs is shown in the Remotes section of the 
Remotes tab. 

 

At power-up the hardware scans the Remote Bus and compares the Type and ID of the 
hardware-detected Remotes with the Type and ID of the Remotes in the list.  If there is a 
match, then the detected Remote uses the settings defined by the listed Remote.  If there is an 
ID match but a Type mismatch, or if there is no Type and ID match at all, then the detected 
Remote is automatically added to the Remotes list, along with its Type and ID.  The Remote 
Controls themselves do not store any configuration information.  If a Remote Control is moved 
to a different DX1208 it must be reconfigured from the Remotes tab of the new DX1208. 

Remotes Parameters 
• Name Each Remote can be given a Name to identify its function or 

location. 

• Type Selects which type of Remote Control is assigned to the ID.  
Setting the Type to [UR-1] enables the UR-1 and disables the UR-
2 programming controls.  Conversely, setting the Type to [UR-2] 
enables the UR-2 and disables the UR-1 programming controls.  
The Type setting for Present Remotes cannot be changed. 

• ID Sets the ID of the Remote.  This ID must match the physical 
address as set on the Remote’s 8-position DIP switch (see 
Universal Remote Control - Quick Start Guide for instructions on 
setting the physical address).  IDs can range from [0] to [127].  
The ID setting for Present Remotes cannot be changed. 
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• Enable Allows the selected Remote to control the DX1208.  Enabled 
Remotes are indicated by a [1]; disabled Remotes are indicated 
by a [0].  Disabling a Remote Control prevents it from changing 
the assigned Functions.  However, even when disabled, a 
Remote’s LEDs continue to display the current state of the 
assigned Functions.  For example, if the encoder of a disabled 
UR-1 is assigned to an [I/O Gain], then the encoder LED ring will 
reflect any changes to that Gain setting made from DX Navigator.  
All new Remotes that are detected at power-up are enabled by 
default. 

• New Adds a new Remote to the Remotes list.  New Remotes are 
added starting at the lowest unused ID.  Up to 100 Remotes can 
be added to the Remotes list, inclusive of all Remotes present at 
power-up. 

• Clear Removes the selected Remote from the Remotes list.  Clearing a 
Present Remote clears the Name and Enable parameters and all 
Functions assigned to the Remote, but does not remove the 
Remote from the list; Present Remotes cannot be removed from 
the list unless the Remotes become disconnected from the Bus for 
more than 10s. 

• Present Indicates whether a Remote is detected on the RS-485 Remote 
Bus when the unit is powered-up.  Detected Remotes are 
indicated by a [1]; user-defined Remotes and detected Remotes 
that later become disconnected from the DX1208 for more than 
10s are indicated by a [0].  Remotes must be connected to the 
DX1208 prior to power-up to be detected; if they are connected 
afterwards the DX1208 will not recognize them. 
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UR-1 Parameters 

 

• Encoder Function Defines which DX1208 parameter(s) the Remote controls 
[None] Disables the encoder knob. 
[I/O Gain] Allows gain adjustment of any of the 12 Input or 8 

Output Channels. 
• Encoder Select Assigns a specific Input or Output Channel to the [I/O Gain] 

Encoder Function. 

• Button Action Determines whether the button action is momentary or latching. 

[Momentary] The Button Function is activated only as long as the 
button is pressed and held. 

[Latching] The Button Function is activated when the button is 
first pressed and remains activated when released; it 
is deactivated when pressed and released second 
time. 

• Button Function Defines which DX1208 parameter(s) the Remote controls. 

[None] Disables the Remote button. 
[Preset] Recalls the Preset number chosen in the Button 

Select setting. 
[Priority] Triggers the ducker Priority level chosen in the 

Button Select setting. 
[Mute All In] Mutes and unmutes all Analog, Digital, and DX Link 

Inputs. 
[Mute All Out] Mutes and unmutes all Analog and DX Link 

Outputs. 

 49



[Mute Ch] Mutes and unmutes only the Input, Output, or DX 
Link channel chosen in the Button Select setting. 

• Button Select Assigns a specific Preset, Priority level, or Input/Output Channel 
number to the [Preset], [Priority] or [Mute Ch] Button Function. 

• Button State This indicator lights when the Button Function is active, and is dim 
when inactive. 

UR-2 Parameters  
The UR-2 parameters are identical to the UR-1 Button Action and Function parameters 
described above, except that a different Button Function can be assigned to each of the 4 
buttons. 

• Select Selects which of the four buttons to which the Button Action, 
Function, and Select controls apply. 

 

Device Window – Settings Tab 

Presets 
Description 
The DX1208 allocates 24 namable Preset memories for storing and loading DX1208 
parameter settings.  Presets are stored in non-volatile memory, and so are retained when the 
unit is powered off.  When the unit is powered on again, the designated Power-on Default 
Preset is loaded.  Preset loads can be triggered from Remotes, Logic Inputs, dedicated RS-
232 controllers, as well as DX Navigator. 

All user-editable parameters are stored to Presets except for the following: 

• Preset Power-on Default 
• Admin and User Passwords 
• DX Link Master / Slave setting 
• IP settings (all) 
• Remote settings (all) 
• Logic I/O settings (all) 
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Parameters 
• Preset Name Each Preset can be given a user-defined name of up to 16 

characters in length.  When a Preset is loaded, the name of the 
loaded Preset appears in the Preset Name text box; when a 
Preset is stored, the name currently in the Preset Name textbox is 
stored into the Selected Preset along with the other DX1208 
parameter settings. 

• Selected Preset Selects the Preset that will be used for Load, Store, Clear, and Set 
operations. 

• Load Loads the parameter values stored in the Selected Preset into 
active memory.  After pressing Load, the Preset Loading progress 
dialog appears, showing the number of the Preset being loaded, 
and whether or not the Preset was triggered locally or remotely.  
Preset loads usually take several seconds to complete while the 
current device parameters are updated to the new values. 

 

• Store Stores the current values of all device parameters (except where 
noted above) as well as the Preset Name into the Selected 
Preset.   

• Clear Erases the Selected Preset, and marks the cleared Presets as 
‘(default)’ in the Selected Preset list.  Loading a cleared Preset 
resets the unit to a factory default state. 

• Set Makes the Selected Preset the Preset that is automatically loaded 
when the unit is powered on. 

• Power-On Default Displays which of the 24 available Presets will be automatically 
loaded when the unit is powered on.  If the Power-on Default 
Preset has been cleared, then the unit will be reset to the factory 
default state on power up. 

Permissions 
Description 
The DX1208 can be secured against unauthorized use by requiring users to log into the 
hardware to gain access to Device Windows.  The DX1208 supports two user access levels, 
called Permissions: Administrative and User.  Administrative Permission grants the user full 
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access to the hardware through the Device Window.  User Permission grants the user the 
ability only to load Presets, view the Event Log, and view the Input/Output Channel Strip 
through a highly abridged version of the Settings tab.  Permissions do not prevent individuals 
from controlling units from Logic Inputs and Remotes; Permissions only restrict control from 
the Device Window and RS-232 port.  Design Windows are not access-restricted because 
they do not directly control hardware. 

 

When Permissions are active, a Password is required to login to the Device Window.  Double-
clicking a hardware unit’s Device Icon in the Found Devices tab of the main DX Navigator 
window opens the DX1208 Password dialog, as shown here: 

 

To login, select a Permission Level and enter the appropriate password for that Level.  As 
shipped from the factory, the DX1208 Admin and User Passwords are both blank.  If the 
Password for either Permission Level is blank, then simply clicking the Login button gives the 
user de facto permission for the selected Permission Level.  Once a Password is set the 
change takes effect immediately; the next time you login you must enter a Password to gain 
access to that Permission Level.  Setting a blank Password removes the Permission for that 
Level, once again allowing de facto access to that Level. 

Administrative Permission is required to create or change Permissions.  Make sure that you 
don’t leave the Admin Password blank after setting the User Password, otherwise users will 
still have unrestricted access to the hardware. 

Passwords are stored within each unit in non-volatile memory, and each unit may have its own 
unique User and Admin Password.  Therefore for any given hardware unit, the same Admin 
and User Passwords are required to login from any instance of DX Navigator, regardless of 
where the computer is located.  System administrators can use this feature to segment larger 
topologies into subsystems by login Permissions. 
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Parameters 
• Admin Sets the for Administrative-level access.  Admin Passwords may 

be up to 16 characters in length, contain any combination 
alphanumeric characters, and are case-sensitive. 

• User Sets the Password for User-level access.  User Passwords may 
be up to 16 characters in length, contain any combination 
alphanumeric characters, and are case-sensitive. 

• Set Password Sends the (User or Admin) Password to the DX1208 hardware.  
Once set, all subsequent logins will require you to enter the 
Password to gain (User or Admin) access to the Device window.  
Pressing Set Password with the Admin or User fields blank will 
effectively disable that Permission. 

IP 
Description 
All DX series hardware devices can be configured to communicate with DX Navigator over a 
local (LAN) or wide-area (WAN) Ethernet network using either static or dynamic IP addressing 
methods.  They can also communicate over peer-peer Ethernet connections using an Ethernet 
‘crossover’ cable to connect the computer directly to the hardware without intervening nodes 
(including routers, hubs, switches, etc.). 

Always consult with the network administrator before connecting any DX device to a non-
dedicated corporate network.  The network administrator will determine an acceptable range of 
IP settings that are compatible with the logical configuration and topology of the network.  
Failure to adhere to the administrator’s IP assignment conventions may cause 
communications failures not only with the DX device, but also with other devices connected to 
the network.  

Therefore to prevent such problems, configure the device’s IP settings with the device 
disconnected from the network using a COM (USB or RS-232) connection.  When finished, 
power cycle the unit, then connect the device to the network; IP setting changes do not take 
effect until after the device is power cycled.  On some networks it may take several minutes 
after making IP setting changes before your DX device becomes visible to DX Navigator. 

Dynamic IP 
Dynamic IP allows a device’s IP settings to be automatically configured by a DHCP server 
(typically a router or gateway device).  When configured for dynamic IP operation, DX devices 
will request an IP configuration from a DHCP server each time they are powered on or 
connected to the network.  If a DHCP server is present on the network, then the device 
automatically configures its IP settings using the settings provided by the server.  Therefore a 
DX device’s IP settings may change each time it connects to the network, or whenever the 
DHCP lease period for that device expires.  Therefore whenever a device is configured for 
dynamic IP, you must set the DX Navigator communications mode to Obtain IP Address By 
Broadcast (see Communications Setup) in order to communicate with it. 
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All DX series hardware devices come factory configured for dynamic IP operation.  Since most 
corporate networks employ DHCP servers, a general rule you will not need to change a DX 
device’s IP settings before placing it onto a corporate network.  However, if you are not sure if 
there is a DHCP server on the network, ask your network administrator. 

Static IP 
With static IP operation, DX devices are manually set to a specific IP address.  Static IP 
operation is required whenever there is no DHCP server on the network, as is normally the 
case in peer-peer connections, or in small networks using only switches and hubs to connect 
all of the devices.   It is also required when either DX Navigator or one or more DX devices are 
connected to different subnets (see Communications Setup).  An example of this would be 
where you have a computer running DX navigator at your office, and want to connect to the 
devices at a client’s site over the internet. 

 

 

Static IP operation can also be used on networks that have DHCP servers.  DHCP servers can 
usually be programmed to automatically assign dynamic IP addresses within a certain address 
range, and reserve other addresses for static IP assignments.  In larger networks, it is often 
the case that static IPs will be assigned to certain devices like printers, web servers, and file 
servers, while the vast majority of remaining devices (desktop / portable computer systems) 
will be assigned IPs dynamically.  Consult with your network administrator to find out which 
static IP address ranges are available for use. 

Parameters 
• IP Mode The IP Mode checkbox (not labeled) determines whether the 

device is configured for dynamic or static IP operation. 
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[Dynamic] When unchecked, the unit is set for dynamic 
(automatic) IP configuration by a DHCP server.  A 
DHCP server must be present on the network to use 
this setting. 

[Static] When checked, the unit is set for static IP operation 
using the Static IP, Subnet, and Gateway settings.   

• Static IP Sets the static IP address of the unit.  For private networks (i.e. 
networks in which the IP addresses of its host devices are not 
visible on the public Internet – as is almost always the case in 
home, small office, and corporate networks), RFC1918 defines a 
range of IPv4 addresses that can be used: 

Name IP Address Range 

24-bit block  10.0.0.0 – 10.255.255.255 

20-bit block  172.16.0.0 – 172.31.255.255  

16-bit block 192.168.0.0 – 192.168.255.255 
 

• Subnet Sets the subnet mask of the unit.  The subnet mask is used to 
divide a larger network into smaller subnetworks.  It is extremely 
important to note that while devices can use any valid IP address 
within the prescribed range, all devices placed on the same 
subnet MUST use the same subnet mask.  The largest subnet 
masks corresponding to the private IP address ranges listed 
above are as follows: 

Name Subnet Mask 

24-bit block  255.0.0.0 

20-bit block  255.240.0.0 

16-bit block 255.255.0.0 
 

• Gateway Sets the IP address of the network gateway.  A gateway is a 
network computer or device (like a router) that acts as a bridge to 
another subnet within the same network, or an external network 
(such as the Internet).  In small networks where all devices 
(including the DX navigator computer) are connected to the same 
subnet, the Gateway setting can be left blank [0.0.0.0]. 

• Dynamic IP Displays the IP address currently assigned to the device by the 
network DHCP server when set to [Dynamic] operation. 

Small Network Setup Example 
Network design and configuration depends greatly on how devices are meant to communicate 
with each other as well as what devices are meant to be able to communicate.  While the topic 
of network setup and configuration is beyond the scope of this manual, this section illustrates 
how to setup a small private network using static IP in the absence of a DHCP server.  Such a 
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network can be easily created by connecting one or more computers running DX Navigator to 
one or more DX series hardware devices through Ethernet switches or hubs.  This example 
also applies to setting up a peer-peer network by connecting a computer directly to a DX 
device using an Ethernet crossover cable. 
 
Every device that is connected to an Ethernet network (computer, printers, DX series 
hardware devices, etc.) must have a unique IP address.  As long as your network doesn’t 
connect to any other network, you can assign each device an arbitrary IP Address.  However, 
each device must be set to the same subnet mask. 

In the absence of a DHCP server, Windows XP and Windows Vista computers are typically 
setup automatically configure their own IP addresses using link-local_addresses based on the 
zeroconf addressing techniques.   RFC 3927 recommends that link local addresses fall within 
the range between 169.254.0.0 and 169.254.255.255, and use a subnet mask of 255.255.0.0.  
For purposes of this example, let each Windows computer configure its own IP address.  
Because DX devices do not support zeroconf link-local addressing, their IP address will need 
to be manually configured to be compatible with the computer’s link-local addresses. 

To setup one or more DX devices for operation with zeroconf-addressed Windows computers: 

1. Connect the first DX device to any computer using USB communications (see 
Communcations Setup). 

2. Launch DX Navigator and go online (see Going Online). 

3. Login to the device, and change the following settings in the IP section of the Settings tab: 

a. Check the IP Mode checkbox. 

b. Enter [169.254.0.1] into the Static IP textbox. 

c. Enter [255.255.0.0] into the Subnet textbox. 

d. Because the network in this example does not connect to any other network, the 
Gateway setting is not used and can be left set to [0.0.0.0]. 

 

4. Close the Device Window and go offline with DX Navigator. 

5. Power cycle the DX1208 for the IP setting to take effect. 

6. Connect the DX device to a hub or switch using a standard Ethernet cable; OR if setting up 
a peer-peer connection, connect the DX device directly to the computer using an Ethernet 
crossover cable. 
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7. Repeat steps one through six for each DX device you are connecting to the network.  Set 
the Static IP of the second device to [169.254.0.2], the third to [169.254.0.3], and so forth. 

8. Now connect each of the computers you will be using to the network.  Each computer will 
automatically configure its IP address using zeroconf addressing negotiation.  It may take 
several minutes for the computers to finish configuring themselves. 

9. The network setup is now complete.  If you wish to know the IP addresses of each 
computer or DX Navigator is unable to see one or more devices, refer to the 
Troubleshooting section below. 

Troubleshooting 
If DX Navigator is having trouble discovering one or more units on the network, then you can 
use Windows’ built-in IP communications verification applet to determine whether your 
computer is able to send and receive IP packets from a particular device.  To use this applet, 
your computer and the device in question should be located on the same subnet. 

1. <CLICK> Start on the Windows Taskbar and select Run from the Start menu. 

2. In the Run dialog, type ‘cmd’, then <CLICK> the OK button.  The Command Prompt 
window opens. 

 

3. At the prompt, type ‘ping’ followed by a space, then the full IP address of the device.  
Windows begins sending IP packets to the device.  If it finds a device at that address it 
reports that it received a reply from the device along with the total latency of the 
communications loop.  If it does not find a device it reports that the ‘request timed out’. 
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4. To verify the current network IP settings of the computer you are using, type ‘ipconfig 
/all’ at the prompt.  The computer returns both the IP settings of the device as well as 
other useful information, such as the NIC card’s MAC address, and the DHCP enable 
status. 
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Event Log 
Description 
The Event Log records details of all significant events that occur within the DX1208 hardware.  
The Event Log can store up to 2048 events, which are written to non-volatile memory and 
retained indefinitely after the power is turned off.  When the Event Log becomes full, the oldest 
1024 events are deleted and replaced by new events until the Event Log fills up again.  Event 
types include administrator and user logins, power-ons, and error messages.  Contents of the 
event log are displayed in the UI in a tabular format.  Each log of the line records a single 
event with the date and time of its occurrence, a brief event description, some 
status/diagnostic codes, and the DX1208 firmware version running at the time of the event.  
Users can save the displayed contents of the Event Log to a tab-delineated text file to assist 
with troubleshooting or create permanent records of unit activity. 
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Commands 
• Refresh Refresh sends a request to the hardware to return the current 

contents of the Event Log.  The log is not updated in real-time; a 
Refresh command must be sent to view any events that have 
posted to the log since the last Refresh command. 

• Clear Clear erases the contents of the Event Log memory in hardware 
and clears the DX Navigator Event Log display. 

• Save Saves the current contents of the Event Log to a tab-delineated 
text file for archiving or for assisting with hardware 
troubleshooting. 

• Current Time The Current Time display mirrors your computer’s date and time 
settings.  The Event Log time-stamps all events relative to the 
Current Time.  Setting up your computer to automatically 
synchronize to an internet time server will insure that all logged 
events will be referenced to the national time standard (atomic 
clock).  This is especially important if you need to correlate event 
times across multiple computers running DX Navigator. 

Saving the Event Log 
1. <CLICK> the Event Log Save button. 

2. In the Save As dialog, navigate to the folder where you want to store the file. 

3. Enter the name of the file in the Filename text box, and <CLICK> Save. 
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Synchronizing Current Time to an Internet Time Server 
1. Open the Windows Date and Time Properties window: 

� Select Start on the Windows Taskbar and then choose Control Panel > Date & Time; 
or 

� <DOUBLE-CLICK> on the Time Display in the lower-right corner of your computer’s 
screen. 

2. Select the Time Zone tab and choose the Time Zone (relative to GMT) in which your 
computer is located. 
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3. Select the Internet Time tab and choose one of the time servers listed in the Server drop-
down menu.  <CLICK> the ‘Automatically synchronize with an Internet time server’ 
checkbox, and press the Update Now button.  <CLICK> OK when done. 
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DX Link Clocking 
Description 
When multiple DX1208 units are connected via DX Link, their sample clocks must be 
synchronized to a common master clock source.  One DX1208 must be set as the master 
device, and all others must be set to slave devices, regardless of how many units are 
connected together. 

 

NOTE:  Failure to configure a multi-unit system exactly as described will cause sample 
clock conflicts between one or more devices.  This in turn will cause no audio 
to pass through one or more DX Link connections. 

Parameters 
• Master/Slave Sets whether the device is a clock [Master] or clock [Slave]. 

DX Link Status 
Description 
These two LEDs indicate the status of any signal present at the units DX Link Rx (receive) 
jack. 

 

Indicators 
• DX Cable Present Lights when a signal is present at the unit’s DX Link Rx (receive) 

jack.  If this indicator is lit but the DX Link Active indicator is not, 
then the signal is either not valid, or the signal is asynchronous 
with respect to the unit’s internal sample clock.  When this 
condition occurs verify that the DX Link Master/Slave settings for 
all units have been correctly configured (see DX Link Clocking), 
and that all DX Link cables are properly seated in their jacks. 

• DX Link Active Lights when the signal present at the unit’s DX Link Rx jack is 
synchronous with the transmitting unit and the audio is valid. 

Firmware Version 
For Device Windows this text fields lists the current embedded firmware version of the 
connected DX1208 device.  For Design Windows these fields are blank.  Consult the release 
notes for the version of DX Navigator you are running to verify whether the DX1208 devices in 
your system are running compatible firmware.  It is particularly important in larger systems with 
multiple locations and/or DX Navigator client installations that both software and firmware be 
upgraded for the entire system at one time to avoid compatibility issues between DX Navigator 
and the installed firmware. 
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Device Window - User Tab 
When an individual logs into the DX1208 as a User, an abridged version of the Settings tab 
appears.  All other tabs are hidden.  From this window users may load Presets, refresh and 
save the Event Log, and view the DX Link Status.  They can also view the Input/Output 
Channel Strip controls (Meters, Gains, and Solo and Mute status), but cannot change any of 
their settings. 

 

4. e. 
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